Is WP Courseware compatible with all Themes and Plugins?

There are literally thousands of themes and plugins available within the WordPress community. We have done quite a bit of testing; however, it would be impossible to test with all themes and plugins available. We have found that WP Courseware works well with most all themes and plugins.

Here is a rule of thumb. If WP Courseware has an issue in the way it functions on your site there are couple things you can do to troubleshoot this.

Rule out any theme conflicts

  1. Change to one of the default WordPress themes like Twenty Twelve.
  2. Test to see if the issue still exists.
  3. If the issue disappears it could be an issue with your theme. Check your theme's settings and configuration to see if you can spot a setting that might be triggering the conflict. Usually if there is a theme conflict, it has to do with JQuery.
Check for any plugin conflicts
  1. Disable all plugins except WP Courseware.
  2. Check to see if the issue is gone. If the issue is gone, then it is probably a plugin conflict. Proceed to step 3.
  3. Enable each plugin one by one, testing to see if the issue returns.
  4. If you enable a plugin and the issue returns, you have found the conflicting plugin.
  5. Check the plugin's settings and configuration to see if you can spot a setting that might be causing the conflict.
We have noticed that "Post Ordering" plugins tend to conflict with WP Courseware because of our drag and drop module/unit functionality.

Still need help? Contact Us Contact Us